Wednesday, August 6, 2008

3 Days and 40 Frickin' Dollars

The last few months, I've been referring to my computer as "the worst computer I've ever owned."

About a year-and-a-half ago, I ordered a new computer from Using that particular site as my purchase-point was off of the recommendation of a friend, and that same friend helped me pick out a selection of parts that would work properly together. I am, as I always say, not a "hardware guy." I can read through a pre-packaged computer's stats and look for the important bits, but picking what processor to go with what motherboard is a whole different ball of wax.

So I picked out a bunch of parts, paid $75 to have Mwave assemble and test the machine, and they sent it on over. Man, it was sweeeeeet. I went from playing EQ2 on the absolute minimum settings to being able to run comfortably on medium, or even on high if I wanted to push it for screenshots (mostly I kept my settings lower than I had to so as to not overwork my hardware, in theory making the computer last longer).

I've owned a number of computers in my life, going all the way back to my Laser 128 EX (Apple II compatible), which never once gave me hardware trouble. I don't think I've ever had a computer that showed signs of distress before its second birthday, and I'll even include my wife's computers in that list (she's had 3 since I met her, but never got rid of one because it stopped working).

This computer lasted a whopping 7.5 months before trouble hit. One day, the computer wouldn't turn on. After a little experimentation, I found that if I flipped the switch on the back of the power supply, waited a few seconds, and then flipped it back on, the computer would allow me to turn it on again.

Within a couple weeks, however, this problem degraded - requiring longer rest periods when switched off - eventually reaching a point where that trick no longer worked. I had contacted Mwave before the computer absolutely died, and got information on where to send it for repair. By having them assemble the machine, it came with a 1 year warranty. Hooray?

I had my computer boxed up and sent it to the Mwave service center for about $40, between packaging and shipping.

About 3 weeks later, I was told that after extensive testing of various parts, my computer's failure to turn on was due to a bad video card.

Yes, I said video card.

Even with my limited hardware knowledge, this sounded really strange. When I told my more hardware-savvy friends of problem, we all agreed it was either a bad power supply or a broken motherboard. This solution puzzled them, too.

I was wary when the computer arrived back at my house, but I hooked everything up and was pleasantly surprised to find it was fully operational. I guess, somehow, the video card was SO broken, that it was keeping my entire computer from working!

Little did I know, at the time, that the particular model of video card I had purchased was rife with bad memory chips that caused severe artifacting issues. My original card was seemingly one of the few that didn't have that particular problem. My new one did.

At first, the artifacting was too minor to be a hassle. Once in a while I'd log into EQ2 and my cloak would be doing strange things, but the next time I zoned it would be back to normal.

Later, I started getting stuck pixels on my monitor. It was my first LCD monitor, and I knew this was a risk, so I took it to Best Buy and had them look it over, but they couldn't find anything wrong with it. I didn't realize that the stuck pixels were from my video card.

When a friend gifted me a copy of Lord of the Rings Online, the artifacting became slightly more-pronounced. I found odd white bars occasionally sitting on my screen, but refreshing the display by toggling between full-screen and windowed mode would make it go away.

It turns out that EQ2 isn't coded to rely much on video cards, and a newer engine like LotRO is. I might have noticed the bad video card much sooner otherwise.

The problems got worse and worse until I couldn't ignore it anymore. Limbs would veer off in random directions, the landscape would display in a seizure-inducing, flickering checkerboard pattern, and in time, the display-toggle/refresh trick stopped working.

I tried reformatting the entire PC, updating drivers, and so on, but nothing made it better. I started researching the artifacting issue and that's when I became aware that my particular video card was known to be a troublemaker.

...And then...
...In the midst all the other bad news...
...The power problem returned!

The exact same goddamn issue reared its ugly head again! Well, this was too much, so I contacted Mwave and informed them of both of current problems.

Their response? Since my computer was now more than 1 year old, it was no longer covered under warranty, and I had to deal with it all on my own.

Fuck. That.

Firstly, they gave me a bad video card only a few months ago, and they won't support it. Secondly, the original problem I had was clearly never fixed properly DURING the warranty period, and now they won't show some integrity and do the job right!

I was pisssssssed. Hell, I still am.

I entered a process with Gigabyte (the video card manufacturer) that - all told between emails and actual service - took nearly 3 months. They let me send the video card back, couldn't repair it, and sent me a new one, thankfully of a different model.

Not-too-surprisingly, when I did the work myself, replacing the video card did NOT solve the power problem! I can almost hear you gasping in surprise.

But, a couple days after installing the new video card, I started getting messages that the video card performance was being downscaled due to a lack of power.

I went to, bought a new CoolerMaster ATX power supply for $40 (after rebate), waited 3 business days for shipping, and then fumbled my way through a successful power supply switch-out (it looked a lot scarier than it really was).

Guess what the results were? Anyone? Bueller?

1) My computer turns on and off reliably every time!
2) My video card works wonderfully!

I can't believe that I could have saved myself almost a year of headaches just by buying a new power supply. Had I spent $40 on the new power supply THEN, I would have held onto the original, working video card, not suffered two stints of extended downtime (which played no small part in the slow death of my awesome EQ2 guild), AND saved a goodly chunk of money on shipping costs to Mwave and Gigabyte!

I hate you, Mwave. I hate you as much as any gamer can hate a hardware supplier.

In case it wasn't clear, I won't be ordering from you assclowns ever again!!!!